Διόρθωση flickering στο KDE Plasma

Προσωπικά δεν εγκαθιστώ KDE διότι δεν γνωρίζω πως να παραμετροποιήσω το περιβάλλον. Προτιμώ το GNOME.
Έτυχε να εγκαταστήσω το KDE Plasma σε υπολογιστή φίλου. Δεν γνωρίζω τον λόγο αλλά η εικόνα τρεμόπαιζε όταν ελαχιστοποιούσα ή μεγιστοποιούσα τα παράθυρα. Η κάρτα γραφικών του είναι AMD αλλά στο Ιντερνετ βρήκα να συμβαίνει και σε Intel. Στο Internet βρήκα τα εξής (θα τα γράψω στα Αγγλικά αλλά έχω την φωτογραφία στα Ελληνικά):

1. Ανοίξτε System Setting > Hardware > Display and Monitor > Compositor και αλλάξτε το Tearing Prevention (Αποτροπή κοψίματος εικόνας) σε "Full screen repaints" (Πλήρης ανασχεδίαση οθόνης).


Εμένα αυτό το έλυσε μέχρι την επανεκκίνηση, όπου εμφάνισε το ίδιο. Πιθανό αν άλλαζα το Ταχύτητα κίνησης να έλυνε το πρόβλημα. Οπότε προχώρησα στο επόμενο.

2. Στην επιλογή Rendering Backend (Σύστημα υποστήριξης αποτύπωσης), το γύρισα σε XRender. Μετά από επανεκκινήσεις, δουλεύει μια χαρά.

3. Κάτι που δεν δοκίμασα αλλά το βρήκα στο δίκτυο ως λύση είναι το εξής:

Δημιουργήστε ένα αρχείο script στο /etc/profile.d με όνομα kwin.sh (οποιοδήποτε όνομα να είναι δεν μας πειράζει)

sudo nano /etc/profile.d/kwin.sh

και εισάγετε την μεταβλητή:

export KWIN_TRIPLE_BUFFER=1

Αυτό συνίσταται αν στο αρχείο .xsession-errors βλέπετε ότι δεν είναι διαθέσιμο το Triple Buffering.

3 σχόλια:

  1. Από σχολιασμό στο Google Plus

    Το πρόβλημα συνήθως δεν είναι στο ίδιο το γραφικό περιβάλλον αλλά οι drivers της κάρτας γραφικών. Και στις amd και στις intel κάρτες χρειάζεται η επιλογή:

    Option "TearFree" "true"

    στο xorg.conf.

    Επίσης το Xrender δεν είναι από τα προτεινόμενα backends παρά μόνο αν όλα τα υπόλοιπα δεν δουλεύουν γιατί σε εκείνη την περίπτωση δεν έχεις υποβοήθηση από την κάρτα γραφικών για το rendering των εφε.

    ΑπάντησηΔιαγραφή
    Απαντήσεις
    1. Με το KDE Plasma 5.5.1+ δεν τρεμοπαιζει η εικονα σε καμια περιπτωση.

      Το προβλημα που ειχα εγω ηταν που σταματουσε (παγωνε) ο kwin και παγωνε ολο το συστημα, αλλα με την αντικατασταση του kwayland-git αντι του kwayland, και την προσθηκη ενος plugin ακομα με το ονομα kwayland-integration βλεπω να εχει λυθη το προβλημα.

      Η συζητηση ξεκιναει απ το Post#33:

      https://forum.manjaro.org/index.php?topic=29006.30

      Διαγραφή
    2. Ακυρο το παραπανω με τα plugins. το ξανακανει!
      Τωρα δοκιμαζω το Rendering Backend. Το γυρισα σε XRender.

      Διαγραφή

Σημείωση: Μόνο ένα μέλος αυτού του ιστολογίου μπορεί να αναρτήσει σχόλιο.

Από το Blogger.